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TOOLS CHECKLIST  

• Accessibility Checker 
• Action Wizard 
• CommonLook/Allyant (if applicable) 
• Edit PDF  
• Prepare Form 

ACCESSIBILITY TOOLS 

ACCESSIBILITY CHECKER 

The accessibility checker tool automatically checks for accessibility issues found in the PDF 
document. Using the accessibility checker tool is one way to quickly detect any errors that the 
document might have. However, users should not completely rely on this tool as the only 
method to check for accessibility, thus, manual check is needed to resolve any unnoticeable 
problems that were not recognized by the automated checker.  

HOW TO ADD ACCESSIBILITY CHECKER TOOL TO SHORTCUT: 

1. Navigate to the Tools Tab. 
2. Enter “Accessibility” using the search text field. 
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3. Select Add to add the tool into your shortcut pane that appears on the right-hand side. 

 
4. Navigate back to the PDF tab that you were working on to see the newly added 

Accessibility checker tool. 

 

ACTION WIZARD 

Action Wizard allows user to go through series of steps to ensure the document is properly set 
up before running the full check on accessibility. This method includes recognizing text using 
OCR, detect form fields, set tab order, set reading language, tag the document, and set 
alternative text for available images.  
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Note: Optical Character Recognition (OCR) is the process of converting an image of text into a 
selectable text format. For example, if the document is scanned and saved as an image file, you 
cannot use Adobe Reader to edit, select, and search the text of an image file. Thus, OCR enables 
the scanned image to be converted into an editable text format that can be edited, selected, 
and searched. 

HOW TO ADD ACTION WIZARD TOOL TO SHORTCUT: 

1. Navigate to the Tools tab.  
2. Enter “Action Wizard” using the search text field. 
3. Select Add to add the tool into your shortcut pane that appears on the right-hand side. 

 
4. Navigate back to the PDF document to view the newly added Action Wizard tool on the 

right-side panel. 
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COMMONLOOK PDF/ALLYANT  

CommonLook PDF (also known as Allyant) is a remediation software that assists in making 
documents accessible. Adobe Acrobat integrated CommonLook as a plugin and can be accessed 
while using Acrobat. CommonLook PDF provides ease of use and many more features for 
document remediation that is not supported by Adobe Acrobat. 

To read more about the differences between Adobe Acrobat and CommonLook PDF, refer to 
Comparing Adobe Acrobat DC and CommonLook PDF. 

HOW TO INSTALL COMMONLOOK PDF/ALLYANT:    

Refer to the download manual to Install CommonLook PDF .   

HOW TO ACCESS COMMONLOOK PDF/ALLYANT PLUGIN IN ADOBE 
ACROBAT PDF: 

Once CommonLook PDF is installed, you can navigate to the Plug-Ins menu in Acrobat and 
select CommonLook, then choose CommonLook PDF.  

 

HOW TO USE COMMONLOOK PDF/ALLYANT: 

To get started with CommonLook PDF and supporting features, refer to CommonLook PDF User 
Guide. 

https://commonlook.com/wp-content/uploads/2019/04/adobe-acrobat-professional-vs-commonlook-pdf_final-remediated.pdf
https://commonlook.com/user-guides/installing/
https://commonlook.com/user-guides/commonlook-pdf-user-guide/
https://commonlook.com/user-guides/commonlook-pdf-user-guide/
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EDIT PDF 

Edit PDF allows users to edit text and images in a PDF file. Use Edit PDF to fix small issues such 
as text formatting, add/remove links, and arrange objects. It is not recommended to heavily 
rely on Edit PDF tool to fix accessibility issues, thus, those issues must be resolved beforehand 
using Microsoft Word or other editing software before converting to accessible PDF. 

Learn how to edit text and images/objects using the Edit PDF tool: 

• Adobe Acrobat PDF Edit Text User Guide  
• Adobe Acrobat PDF Edit Images or Objects User Guide 

HOW TO ADD EDIT PDF TOOL TO SHORTCUT: 

1. Navigate to the Tools tab. 
2. Enter “Edit PDF” using the search menu. 
3. Select Add to add the tool into your shortcut pane that appears on the right-hand side. 

 

PREPARE FORM 

Prepare form tool is used to build form fields. It is highly recommended using this tool to add 
form fields, set the reading order of the form fields, field properties such as tooltips, and other 
form functionalities.  

https://helpx.adobe.com/acrobat/using/edit-text-pdfs.html
https://helpx.adobe.com/acrobat/using/edit-images-or-objects-pdf.html
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To learn more about Adobe Acrobat Forms, refer to Adobe Acrobat PDF Form Basics. 

HOW TO ADD PREPARE FORM TOOL TO SHORTCUT: 

1. Navigate to the Tools tab. 
2. Enter “Prepare Form” using the search menu. 
3. Select Add to add the tool into your shortcut pane that appears on the right-hand side. 

 

HOW TO ADD FORM FIELDS: 

Using the toolbars in the Prepare Form, select the desire form field to add. 

 

There are various options to choose from the toolbar, however, the most common options to 
add in Adobe PDF: 

• Text Field 
• Check boxes 
• Radio buttons 
• List options 

https://helpx.adobe.com/acrobat/using/pdf-forms-basics.html
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• Drop down options 
• Digital Signature 

FORM FIELD PROPERTIES 

To access form field properties, select the desire the form and right click to choose Properties 
from the context menu. 

Ensure that the Name label and Tooltip is included for each form field. 

Note: the screen reader will only read the Tooltips and not the label text in Focus mode, 
therefore, be descriptive as possible when providing tooltips. 

 

If the text field span more than one line, ensure the “multi-line” check box in the Options tab is 
checked. 
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If adding list or drop-down options, add individual item to the item list in the Options tab. 
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If you want to restrict user input for specific form field such as date, you can navigate to Format 
tab and select from the format category. 
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GETTING STARTED 

STEP 1: CHECK IF THE DOCUMENT IS AN IMAGE 

If the file is an image or scanned document, Adobe PDF would ask to run text recognition 
when you first open the document. 

 

The Recognize Text function performs OCR and converts the image to editable text. 
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If the file is not an image and it contains editable text, use the Check Accessibility feature from 
the Accessibility Checker Tool.  

1. Locate the Accessibility Checker tool on the right-hand panel, click on the icon and 
select Accessibility Check option from the list. 

 
2. Select Start Checking from the Accessibility Checker Options pop-up window. 
3. A list of generated accessibility errors will be displayed on the left-side pane. 

a. Elements with Bold heading indicate accessibility errors that need to be 
resolved. Expand each element to review the issues in detail. We will walk 
through how to fix each issue later in this document. 

 

STEP 2: CHECK IF THE DOCUMENT IS FULLY TAGGED 
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In some cases, the document is partially tagged, thus, the Tagged PDF passed the checklist. In 
other cases, the document is tagged incorrectly that there are numerous errors output by the 
Accessibility Checker. To ensure that the document is fully tagged and quickly reduce 
accessibility errors, use Autotag Document action in the Accessibility Checker.  

Select Autotag Document option from the Accessibility Checker tool. 

 

Note: Autotag Document function does not guarantee that the tags on the tags tree are marked 
correctly. Users must manually check and examine the tags tree for correction. 
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PROPER PDF TAGS 

Tags are encoded syntax or markup that provide structure for content within documents. Tags 
in Adobe Acrobat are like those of HTML tags used on web browser to structure the contents 
displayed on screen. Every piece of information within the document must be tagged correctly 
to enable accessibility for users using assistive technologies. Some of the commonly used PDF 
tags are listed in table 1. 

Table 1 PDF Tags 

Definition Tag Additional Information 

Heading level 1 - 6 <H1> - <H6> 

Each document should have only one Heading level 
1. 

H1 (Heading 1) – Title of the document 

H2 (Heading 2) – Section 

H3 (Heading 3) – Subsection 

And so on… 

Text/Paragraph <P> Regular text that are not headings 

Form <Form> 

Encapsulate the textual content of the form and a 
form object (OBJR). 

Note: Form tag cannot be at the root level and must 
be nested inside another tag (e.g, P, TH, TD, etc.) 

List <L> Encapsulate list items (LI). 

List Item <LI> 
Encapsulate list label (Lbl) and list body (LBody). 

Note: Some list does not need to have a list label 
(Lbl). 

List Label <Lbl> Contains distinguish information such as bulleted 
points or numbered list. 

List Body <LBody> Contains textual information. 
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Definition Tag Additional Information 

Note: In the case of nested list, it may contain an 
additional list (L). 

Table <Table> Encapsulate table rows (TR). 

Table Header <TH> 
Every table should have either a row header or a 
column header. 

Typically nested inside the first table row (TR). 

Table Row <TR> Encapsulate table headers (TH) and table data cells 
(TD). 

Table data cell <TD> Encapsulate data/textual information. 

Image <Figure> Encapsulate an image object. 

Table of Content <TOC> Encapsulate table of contents items (TOCI). 

Table of Content 
item <TOCI> 

Encapsulate the Reference tag for a link to a section 
within the document. 

Note: If the table of contents are not linked, the Link 
OBJR (object) will not be present. 

Link <Link> 

Encapsulate textual information about the link and a 
link OBJR.  

Note: Link tag cannot be at the root level and must 
be nested inside other tags such as P, TH, TD, etc. 

Caption <Caption> 

There are 2 different types of captions:  

1. Figure Caption: provide long description of an 
image. 

2. Table Caption: provide a title for a table. 

Note: Captions cannot contain text as its immediate 
child, thus, textual information must be placed 
inside a Span tag. 
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TAGS TREE 

Tags tree determines the reading order and structure of a document. Users with assistive 
technology rely on the tags in the tag tree for navigation. Like sighted users who skim through 
headings in the document to find different sections of the content, users using assistive 
technology can navigate programmatically to various sections of the contents using headings 
without having to read the entire document. 

To view the tags in the document, navigate to the tag pane on the left-side panel. Using the tag 
pane, you can add, edit, and delete tags from the tag tree. 

 

HOW TO ADD TAGS PANE TO SHORTCUT 

If the tag pane is not already added to Adobe Acrobat shortcut menu: 

1. Navigate to the document menu and select View. 
2. Select Show/Hide. 
3. Select Navigation Panes. 
4. Select Tags. 
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5. The Tag icon will be added to the list of shortcut tools on the left side panel. 

 

HOW TO ADD TAGS TO THE TAGS TREE 

Add individual element as tag in the document: 

1. Navigate to the Tags pane on the left-hand side. 
2. Highlight the desired text on the document. 
3. Select the Options dropdown menu. 
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4. Select Create Tag from Selection option. 

 
5. Choose the Type of tag from the dropdown list. Ignore the title field. 

 

Note: If the newly created tag fell outside of the logical order of the tag tree, simply drag, and 
drop to rearrange the tag in the correct order. 

HOW TO EDIT TAGS IN THE TAGS TREE 

In the case that the elements are incorrectly tagged, you can change the type of tag by 
changing the property of the tag. For example, changing the type of tag from Heading level 2 to 
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Heading level 1. Ensure that the structure of the tag tree remains accessible when you edit 
from the tag tree (i.e., no skipped heading levels). 

1. From the tag tree, right click on the desired tag.  
2. Select Properties. 

 
3. Choose from the Type dropdown menu in the Object Properties pop-up window. 

 
4. Click on Close once you have selected the type. 

HOW TO DELETE TAGS FROM THE TAGS TREE 
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Delete tag from the tag tree if the tag has empty content or does not convey essential 
information in the document such as decorative images or objects. 

1. From the tag tree, right click on the desired tag. 
2. Select Delete Tag. 
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PDF REMEDIATION 

There are different components that check for accessibility in Adobe Acrobat including:  

• Document 
• Page Content 
• Forms 
• Alternative Text 
• Tables 
• Lists 
• Headings 

 

Note: When changes are made on each component, you can rerun the Accessibility Checker to 
see if the issues have been fixed.  

1. While having the Accessibility Checker left panel open, select the Options menu. 
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2. Select Check Again from the drop-down list.  

 

DOCUMENT 

Document metadata provides document-wide properties and information about the document. 
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IMAGE-ONLY PDF 

Image-only PDF error shows that the document is an image and cannot recognize text even 
though there might be text on the document. 

HOW TO FIX IMAGE-ONLY PDF ERROR: 

1. Right click on the error. 
2. Select Fix. 
3. In the Recognize Text pop-up window, set the Output to Editable Text and Images. Click 

OK for the software to perform OCR. 
4. Once the process is completed, the issue should be resolved. 

TAGGED PDF 

Tagged PDF error shows that the document is not properly tagged with logical structure or 
missing tags for every element in the document. 

HOW TO FIX TAGGED PDF: 

1. Right click on the error. 
2. Select Fix. 

 

Tagged PDF fix is like Autotag Document action where the software will eliminate most errors 
by automatically tag every element in the document. You will notice that the number of errors 
will be reduced after the document passed the Tagged PDF error. 
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LOGICAL READING ORDER 

Logical reading order is a manual accessibility check method using the tags tree to ensure all 
the elements are tagged properly as it reflects the visual order of the page. Check for logical 
reading order once all accessibility issues have been fixed. 

HOW TO CHECK READING ORDER:  

1. Navigate to the Tags pane. 
2. From the tag tree, select the first tag. 
3. Using the arrow on the keyboard or mouse, navigate the content from beginning to end 

of the tag tree. 
a. In case the reading order does not match with the visual order of the document, 

rearrange the order of the elements on the tag tree. 

EXAMPLE OF LOGICAL READING ORDER ON A DOCUMENT: 

 

Figure 1 The tags in the tags tree (left) appear in a logical reading order as it reflects the visual 
reading order of the content in the physical view (right). 
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PRIMARY LANGUAGE  

Primary language error shows that the document does not set the primary language that the 
screen reader can use to read information appropriately.  

HOW TO FIX PRIMARY LANGUAGE: 

1. Right click on the error. 
2. Select Fix. 

 
3. Set the primary language of the document. 

 

DOCUMENT TITLE 

Title error indicates missing document title name. Document title is the first thing that the 
screen reader will announce to let the users know what type of document they are viewing 
before reading the body content.  

Note: Document title is required and cannot be left as empty.  

HOW TO FIX DOCUMENT TITLE: 

1. Right click on the Title error. 
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2. Select Fix. 

 
3. Uncheck the option “Leave as Is” for Title. 
4. Enter the Title of the document.  

 
5. Hit Ok once done. 

Note: In some cases that the document already has a title and passed Title error automatically, 
however, it may not have the correct information by using the default file’s name with file 
extension. In that case, users need to manually check for correct document title. 

Example of inaccessible document title: 
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HOW TO MANUALLY CORRECT DOCUMENT TITLE:  

1. Navigate to the File menu in Adobe Acrobat. 
2. Select Properties. 

 
3. Under the Description tab, confirm that the Title for the document is appropriate. 
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BOOKMARKS 

Bookmarks error shows that the document has multiple pages, but none of the pages are 
bookmarked for navigation.  

Note: Bookmark error should be fixed after the headings in the documents are correctly tagged. 

HOW TO FIX BOOKMARKS ERROR: 

1. Right click on the error. 
2. Select Fix. 

 
3. From the Structure Elements pop-up window, choose the headings (H1, H2, H3) for 

bookmarks. Select OK. 
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COLOR CONTRAST  

Color contrast requires manual examination for images, text against background, and objects 
placed within the document. 

HOW TO CHECK FOR COLOR CONTRAST: 

1. Navigate to WebAIM Contrast Checker or using any color contrast checker software of 
choice. 

2. Using the tooltip, check for color contrast between the foreground and background 
color. 

3. Ensure the WCAG (Web Content Accessibility Guidelines) AA requirement passed the 
checker. 

 

https://webaim.org/resources/contrastchecker/
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PAGE CONTENT 

 

TAGGED CONTENT 

Tagged content error shows that not all the elements in the document is tagged properly. In 
some cases, this error is due to new elements are added to the PDF document and have yet 
being tagged. 

Note: all contents in the document must be tagged and show up on the Tags tree. If a graphical 
object is decorative, tag it as an "Artifact". When an object is marked as Artifact, the tag will be 
removed from the Tags tree and prevents screen reader from reading the content aloud. 

There are a few options to tag contents:  

OPTION 1: AUTOTAG 

Note: Autotag should be used when there are numerous Tagged contents failed errors. When 
using the Autotag, the document will reconstruct itself and all the previous tags in the tags tree 
may change. 

1. Navigate to the Accessibility Checker tool on the right panel. 
2. Select Autotag Document option from the list. 

OPTION 2: FIND ELEMENT 

1. Right click on the error. 
2. Select Show in Content Panel. 
3. Find the highlighted element in the Content Panel. You may have to scroll up and down 

to find the element. 
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4. Right click on the element and select Find... 
a. If the element is meant to be tagged as Artifact, select Create Artifact. 
b. In the Create Artifact window, select Page and hit OK. 

5. In the Find Element pop-up window, use the Find dropdown menu to select the 
corresponding option. 

a. If the element is a link, select unmarked Links or Annotations.  
b. If the element is a plain text, select unmarked Content. 

6. Change the Type from Search Page to Search Document if the document contains more 
than one page. 

7. Click on the Find button to find the element in the physical view. 
8. Once the element is highlighted on the screen and the Tag Element is enabled, click 

on Tag Element. 
9. In the New Tag pop-up window, select the Type dropdown to properly tag the element. 
10. Ignore the Title input field and select OK. 
11. If not all elements are tagged, select Find Next and repeat steps 5 to 10. 

OPTION 3: READING ORDER TOOL 

1. Navigate to the Accessible Checker on the right-side panel. 
2. Select Reading Order option from the list. 
3. Draw a rectangle box around the desired element. 
4. Select one of the buttons in the Reading Order toolbox.  

TAGGED ANNOTATIONS 

Tagged annotations error shows that the annotations commonly found in links are not properly 
tagged.  

HOW TO FIX TAGGED ANNOTATIONS: 

1. Right click on the error. 
2. Select Show in Content Panel. 
3. Right click on the highlighted tag in the tag tree and select Find… 
4. Using the dropdown option in Find, select Unmarked Annotations. 
5. Change the select from Search Page to Search Document. 
6. Click Find. 
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7. The action moves to the first element of unmarked annotation that it finds on the 
document with highlighted ring around the text block.  

8. Select Tag Element. 
9. Using the Type dropdown menu in the New Tag pop-up window, select Link. 
10. Ignore the Title entry field and select Ok. 
11. Using Find Next and Tag Element to tag the rest of document. 

TAB ORDER 

Tab order error shows that the tab order within the document used to navigate through links, 
annotations, and form fields are not set in a logical order. 

HOW TO FIX TAB ORDER: 

1. Right click on the error. 
2. Select Fix. 
3. The issue will be automatically resolved and set the tab order in a logical way. 

a. Test the tab order by tabbing through the entire document. 

CHARACTER ENCODING 

Character encoding error shows that the document cannot recognize specific font style that 
does not have unique glyph of the associated characters, thus, computers cannot encode and 
recognize readable text within the document. 

There are various ways to fix character encoding error on the documents. The best practice is to 
refer to the source document (MS Word, PowerPoint, InDesign, etc.) and make changes to 
meet accessibility standards.  

OPTION 1: USE EDIT PDF TOOL IN ADOBE ACROBAT 

use Edit PDF tool in Adobe Acrobat with built-in font style to replace text that produced 
encoding errors. Ensure that the document uses Unicode (OpenType) fonts that support across 
all platforms so that it can be interpreted by assistive technology. 

Best Practice: Use Sans-Serif font style (i.e., Calibri, Arial, Verdana, Helvetica, etc.) to prevent 
character encoding errors.  
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Refer to Adobe Acrobat OpenType learn more about OpenType fonts.  

To utilize the Edit PDF feature in Adobe Acrobat, refer to Adobe Acrobat Edit PDF. 

OPTION 2: REFER TO SOURCE DOCUMENT 

Refer to the source document and check for the accessibility of the document using Check 
Accessibility action. Ensure that the document is using default font style (i.e., Calibri, Arial, 
Verdana, Helvetica, etc.) in Microsoft Word or other editable document software before 
converting the document to PDF. 

What to avoid: 

• Avoid export to Microsoft Word from PDF as many elements in the document can be 
distorted. 

• Avoid printing to PDF as it does not encode the document to be used for accessibility. If 
possible, save the document to PDF or use the PDFMaker plug-in to convert the 
document to PDF. 

OPTION 3: USE TEXT RECOGNITION SOFTWARE 

Use text recognition software such as: 

• Adobe Acrobat built-in tool: Action Wizard. Refer to Action Wizard section to set up the 
document. 

• ABBYY FineReader PDF Application 
o ABBYY FineReader PDF contains OCR Editor that can be used to recognize text in 

images or scanned documents and turn it into editable text that can be highlight, 
select, search, and edit. Refer to ABBYY FineReader PDF User Manual (PDF) to 
learn how to use the OCR Editor.  

 

 
  

https://www.adobe.com/products/type/opentype.html
https://www.adobe.com/acrobat/how-to/pdf-editor-pdf-files.html
https://pdf.abbyy.com/media/1676/users_guide.pdf
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FORMS 

 

TAGGED FORM FIELDS 

Tagged form fields error shows that there are missing form field tags, or they have not been 
tagged properly. See Proper form tag example for more information. 

HOW TO FIX TAGGED FORM FIELDS: 

1. Select Accessibility tool on the right-side panel. 
2. Select Autotag Form Fields action from the list.  
3. The errors should be automatically resolved. 
4. Go to Page Content error and right click to check again. 

a. If the error persists, refer to Fix Tagged Form Fields for alternative methods. 

 

FIELD DESCRIPTIONS 

Field descriptions error shows that there is missing Tooltip description for every form field. 
Tooltip is essential as it is used by assistive technology to tell users of what is expected for each 
field input. 

HOW TO FIX FIELD DESCRIPTIONS: 

https://ode.instructure.com/courses/228/pages/tagged-form-fields?module_item_id=24905
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1. Select the Prepare Form tool on the right-side panel.  
2. Right click on the field element.  
3. Select Properties. 

 
4. Enter the Tooltip for the element in the General tab. 

 
5. Click on Close once done. 

PROPER FORM TAG EXAMPLE 
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<Form> should have the textual content of the form and a form object. 

ALTERNATIVE TEXT 

Alternative text (known as alt text) is a written alternative description of an image. Alt text 
describes the image in detail in consideration of its surrounding context. This information is 
used to read aloud by assistive technology for users with visual impairment.  

 

FIGURES ALTERNATE TEXT 

Figures alternate text error shows missing alternative text in images. Alternative text must be 
added for every meaningful image, otherwise, mark the image as decorative figure to remove 
the element out of the tag tree so that the screen reader will not read this information aloud.  

HOW TO FIX FIGURES ALTERNATE TEXT: 

1. Right click on the error figure and select Fix. 



 
Bob Murphy Access Center (BMAC) 
Accessible Instructional Materials (AIM) Center 
 

38 
Accessible Instructional Materials (AIM) Center 

1250 Bellflower Blvd. AS-116 Long Beach, CA 90840 | 562.985.5401 | aimc@csulb.edu 

 
2. The image on the document is highlighted to indicate that the image needs alternative 

text. 
3. Enter Alternate text in the Set Alternate Text pop-up window. If the image is decorative, 

check the checkbox option for Decorative Figure. 

 
4. Once done, hit Save & Close. 

HOW TO MANUALLY EDIT ALTERNATE TEXT: 

1. Right click on the desired Figure tag from the tag tree. 
2. Select Properties. 
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3. Locate the Alternative Text field and insert description of alternative text. 

 

ASSOCIATES WITH CONTENTS 

Associated with content error shows that there is an "empty" tag that do not have any content 
inside the tag. In some cases, there are empty nested tags that are more difficult to detect. 
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HOW TO FIX ASSOCIATED WITH CONTENT ERROR: 

1. Right-click the element error.  
2. Select Show in Tags Panel. 
3. The element is highlighted in the Tags panel.  
4. Right-click the highlighted element and select Delete Tag from the list.  
5. Repeat and resolve the rest of the errors. 

TABLES 

Tables are used to represent content in a tabular format where there are columns and rows to 
organize information and define relationships between data cells. By applying appropriate 
markup for tables, users with assistive technologies can easily read and understand the content 
in the corresponding table cell. Tables should be made simple and easy to read without merged 
cells or multiple headers. See Proper table tag example for more information. 

To learn more about tables, review W3C Tables. 

 

ROWS  

This error shows that the TR (Table Row) tag is not nested inside the parent tag of Table.  

HOW TO FIX ROWS ERROR: 

1. Right click on the error.  
2. Select “Show in Tags Panel.”  
3. Find the highlighted element in the Tags panel.  

https://www.w3.org/WAI/tutorials/tables/one-header/
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4. Drag and drop to rearrange the tags in the correct location. You may have to drag the TR 
tag and drop inside the Table tag.  

5. In the Accessibility Checker pane, right click on the error and select “Check Again” to 
resolve the issue. If the issue persists, correct the location of the tag. 

If the TR is missing from the tag tree, add the tag to the tag tree. 

TH AND TD 

This error shows that the TH and TD tags are not nested inside the TR.  

HOW TO FIX TH AND TD ERROR: 

1. Expand the error. 
2. Right click on the error element. 
3. Select “Show in Tags Panel.” 
4. Find the highlighted element in the Tags panel. 
5. Drag and drop to rearrange the tags in the correct location. You may have to drag the 

TH or TD tag and drop inside the TR tag. 
6. In the Accessibility Checker pane, right click on the error and select “Check Again” to 

resolve the issue. If the issue persists, correct the location of the tag. 

HEADERS 

This error shows that some tables do not have TH tags.  

HOW TO FIX HEADER'S ERROR: 

1. Right click on the error.  
2. Select “Show in Tags Panel.” 
3. Find the highlighted element in the Tags panel. 
4. Expand the first TR tag within the table. 
5. If possible, change the type of tag from TD to TH. 

a. Right click on the desired tag.  
b. Select Properties. 
c. Under the Tag tab, locate the Type menu option. 
d. Select Table Header Cell. 
e. Hit Close when done. 
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6. In the Accessibility Checker pane, right click on the error and select “Check Again” to 
resolve the issue. 

REGULARITY 

This error shows that there are unequal number of columns in each row or unequal number of 
rows in each column. Commonly, this error shows up on complex tables that have extra empty 
cells or merged cells. 

HOW TO FIX REGULARITY ERROR: 

Option 1: Change the attributes of the column span to cover all the empty cells. 

Option 2: Add empty TD cells to empty cells to set an equal number of columns for each row 
(TR). 

See How to fix regularity failed in Adobe Acrobat (YouTube video) to use either one of the 
options. 

PROPER TABLE TAG EXAMPLE 

 

https://www.youtube.com/watch?v=XVFxMHF4eog
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<Caption>: title of the table. Caption can be placed as the first or last in the Table tag 
depending on the caption's placement in the physical view. 

<Table>: contains at least 1 TR tag and encompasses all other child tags such as TR, TH, and TD. 

<TR>: contains TH tags for the first row and TD tags for the rest of the table. TH indicates that 
the table has column header as the first row of the table. TD indicates that the table has data 
cells for the rows that are not header. Each table row (TR) must have the same number of 
column cells, or the cells must span accordingly. 

LISTS 

Lists are used to organize content in a meaningful and logical way. Several types of lists (i.e., 
bulleted or numbered list) can be applied.  

 

LIST ITEMS 

This error shows that the list item tags (LI) are not nested inside the parent List tag (L).  

HOW TO FIX LIST ITEMS ERROR: 

1. Right click on the error element. 
2. Select “Show in Tags Panel.” 
3. Find the highlighted element in the Tags panel. 
4. Rearrange the list item (LI) tag to nest inside the list (L) tag. 

LBL AND LBODY 

Lbl and LBody error shows that the list label (Lbl) and body (LBody) is not nested inside its 
parent tag of List Item (LI).  
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HOW TO FIX LBL AND LBODY ERROR: 

• Option 1: If the List Item (LI) tag exists within the tag tree, rearrange the element by 
drag and drop List label (Lbl) and body (LBody) inside the List Item. 

• Option 2: If the List Item (LI) tag does not exist within the tag tree, create a new tag, and 
rearrange the element by drag and drop List label (Lbl) and body (LBody) inside the List 
Item. 

PROPER LIST TAG EXAMPLE: 

 

<L>: contains at least 1 List Item (LI). This is the parent tag.  

<LI>: may contain List label (Lbl) tag and always contains at most 1 List body (LBody) tag. This 
tag is nested inside the list (L) tag. 

<Lbl>: contains the bullet/number indicator. This tag is nested inside the list item (LI) tag. 

<LBody>: contains textual content of the list item. This tag is nested inside the list item (LI) tag.

HEADINGS 

Headings provide logical structure to document and form an outline of the page content. This 
allows screen readers to jump quickly between headings of the document, enabling them to 
navigate the document with the same efficiency as sighted users. Headings must be manually 
checked to ensure that every document has at least one Heading level 1 and with the 
appropriate heading hierarchical structure.  



 
Bob Murphy Access Center (BMAC) 
Accessible Instructional Materials (AIM) Center 
 

45 
Accessible Instructional Materials (AIM) Center 

1250 Bellflower Blvd. AS-116 Long Beach, CA 90840 | 562.985.5401 | aimc@csulb.edu 

H1 (Heading 1) – Title of the document 

H2 (Heading 2) – Section 

H3 (Heading 3) – Subsection  

 

Heading structure should follow hierarchical order where H2 is followed after H1, H3 after H2, 
H4 after H3 and so forth. It is acceptable to skip heading level after closing a subsection such as 
moving from H3 back to H2 to start another section of content. 

HOW TO FIX INCORRECT HEADING: 

• If the heading levels are out of order, rearrange the element in the tag tree. 
• If heading levels are skipped, add heading tag. 

 See How to add tags to the tag tree section. 
• If the heading level is incorrect, change its properties. 

 See How to edit tags on the tag tree section. 
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TABLE OF CONTENTS 

Table of contents is used as outline to quickly navigate to sections of the document. To create a 
logical table of contents, all headings and subheadings of the page must be correctly tagged 
prior. Ensure that the contents in the table reflect the page's headings and subheadings.

Table of Contents (without links) 

 

Table of Contents (with links) 

 

<TOC>: Contains at least 1 TOCI (table of content item) tag and encompasses all other child tags 
such as TOCI, Reference/Link, Paragraph, etc. 

<TOC>: may contain Reference/Link tag or Paragraph tag for non-link contents. 

<Reference>: may contain Link OBJR for cross-reference (internal link) or external link. 

LINKS 

Ensure that links on a document are human-readable and descriptive.  

Some important considerations include:  

• Avoid adding full URL to embed a link in PDF unless the document is used for printing. 
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 If you must, provide a descriptive link text and remove the URL from the tags 
tree so it does not get read by screen reader. 

 
• Links should be formatted differently to its surrounding text to indicate the differences 

between regular text and a link. This can be done by using underlined, bolded, or 
italicized the link text. The most common way is to underline the text as most users can 
recognize it as a link.  

• Avoid using color as the only method to present information as many users with color 
blindness cannot distinguish colors. 

 If it is a link, it should be tagged as a link and not using text decoration to 
make it appears like a link.   

EXAMPLE OF A HUMAN-READABLE LINK ON PDF DOCUMENT: 

 

 

<Link> tag encompasses the text of the link and a Link-OBJR. 
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HOW TO ADD LINKS: 

1. Highlight the desired text. 
2. Right click and select Create Link… 

 
3. Locate the Link Action section, select “Open a web page” radio button for external link. 

 
4. Select Next. 
5. Enter the URL address for the link. Then press OK. 
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6. Hover over the text to see the resulting effect. Ensure that the URL appears when the 

mouse is hovered over the text. 

 

HOW TO ADD DECORATIVE TEXT STYLE TO LINKS 

Links must be visually different from its surrounding text to easily identify. Links should be 
accompanied by both color and underline (or some other indicator). Ensure that color is not the 
only indicator that present this information.  

1. Open Edit PDF tool. 
2. Highlight the desired text. 
3. In the Format window, select a color and underline option for the text. 
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4. The customized style of the link should now appear different than the surrounding text. 

 

ACCESSIBILITY TEST WITH SCREEN READER  

Once the remediation process has completed, use JAWS or a compatible screen reader to 
ensure that the document is tagged correctly and read in a logical order.  

If you are using JAWS, one easy tip to catch unnoticeable errors is to use Text Viewer. Text 
Viewer lets users view the text being read by the screen reader.  

HOW TO TURN ON TEXT VIEWER IN JAWS: 

1. Select the Utilities menu. 
2. Select Braille and Text Viewer.  
3. Select Show Text Viewer. 
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RESOURCES 

• WebAIM: PDF Accessibility 

• WebAIM Acrobat Forms 

• HHS Required Fixes for PDF Files 

• Instructure Course Modules: Advanced Accessibility 

• 508 Compliance for Existing PDFs: Identifying & Resolving Common Accessibility Issues 

• Webhelp Making Your PDF Document Accessible (canyons.edu) 

• Adobe Acrobat Pro: Create and verify PDF accessibility  

• Adobe Acrobat User Guide 

• Section 508 Guide Tagging PDF’s in Adobe Acrobat Pro (PDF)  

• DeQue JAWS Keyboard Commands Quick Reference Guide 

• PDF Remediation Basics (Youtube video) 

• Advance PDF Accessibility: Forms (Youtube video) 

https://webaim.org/techniques/acrobat/acrobat
https://webaim.org/techniques/acrobat/forms
https://www.hhs.gov/web/section-508/making-files-accessible/pdf-required/index.html
https://ode.instructure.com/courses/228/modules
https://www.epa.gov/web-policies-and-procedures/508-compliance-existing-pdfs-identifying-resolving-common-accessibility#check
https://www.canyons.edu/administration/it/resources/webhelp/pdf/index.php#:%7E:text=Character%20Encoding%20happens%20because%20the%20PDF%20was%20created,document%20looking%20to%20see%20if%20color%20is%20used.
https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html
https://helpx.adobe.com/acrobat/user-guide.html
https://www.hhs.gov/sites/default/files/pdf-tagging.pdf
https://dequeuniversity.com/assets/pdf/screenreaders/jaws.pdf
https://www.youtube.com/watch?v=ZPRhqbcd6Wo
https://www.youtube.com/watch?v=BPytQ8n66x4

	Adobe Acrobat PDF Remediation guide
	Table of Contents
	Tools checklist
	Accessibility tools
	Accessibility Checker
	How to add Accessibility Checker tool to shortcut:

	Action Wizard
	How to add Action Wizard tool to shortcut:

	CommonLook PDF/Allyant
	How to install CommonLook PDF/Allyant:
	How to access CommonLook PDF/Allyant plugin in Adobe Acrobat PDF:
	How to use CommonLook PDF/Allyant:

	Edit PDF
	How to add Edit PDF tool to shortcut:

	Prepare form
	How to add Prepare Form tool to shortcut:
	How to add form fields:
	Form Field Properties



	Getting started
	Step 1: Check if the document is an image
	Step 2: Check if the document is fully tagged

	Proper PDF Tags
	Tags Tree
	How to add Tags Pane to shortcut
	How to add tags to the tags tree
	How to edit tags in the tags tree
	How to delete tags from the tags tree

	PDF Remediation
	Document
	Image-only PDF
	How to fix Image-only PDF error:

	Tagged PDF
	How to fix tagged PDF:

	Logical Reading Order
	How to check reading order:
	Example of logical reading order on a document:

	Primary Language
	How to fix primary language:

	Document Title
	How to fix document title:
	How to manually correct document title:

	Bookmarks
	How to fix bookmarks error:

	Color Contrast
	How to check for color contrast:


	Page Content
	Tagged Content
	Option 1: Autotag
	Option 2: Find element
	Option 3: Reading Order tool

	Tagged annotations
	How to fix tagged annotations:

	Tab order
	How to fix tab order:

	Character Encoding
	Option 1: use Edit PDF tool in Adobe Acrobat
	Option 2: Refer to source document
	Option 3: Use Text Recognition software


	Forms
	Tagged form fields
	How to fix tagged form fields:

	Field descriptions
	How to fix field descriptions:

	Proper form tag example

	Alternative Text
	Figures alternate text
	How to fix figures alternate text:
	How to manually edit alternate text:

	Associates with contents
	How to fix Associated with content error:


	Tables
	Rows
	How to fix Rows error:

	TH and TD
	How to fix TH and TD error:

	Headers
	How to fix Header's error:

	Regularity
	How to fix regularity error:

	Proper table tag example

	Lists
	List items
	How to fix list items error:

	Lbl and LBody
	How to fix Lbl and LBody error:

	Proper List Tag Example:

	Headings
	How to fix incorrect heading:

	Table of Contents
	Links
	Example of a human-readable link on PDF document:
	How to add links:
	How to add decorative text style TO links

	Accessibility Test with Screen Reader
	How to turn on Text Viewer in JAWS:


	Resources




